Logitech C920 usb cam is found, but picture is black

Russ Holm's Avatar

Russ Holm

29 Apr, 2018 11:52 PM

Hi there,

My old laptop died. It was running sparkbooth 3.8 and worked with my c920 web cam. I got another laptop and downloaded the most recent version (5) of Sparkbooth, and the trial version worked with the camera just fine.

I had to dig for the code to unlock Sparkboth, but found it wasn't compatible with the newer version of Sparkbooth. So, I downloaded the 3.8 version and the code I had unlocked the software....but.....the camera doesn't appear to work. The C920 is listed camera settings drop down, but the camera does not turn on when selected/applied. All attempted photos taken with it are black.

I tried uninstalling the v5 software, but this didn't resolve the problem.

I was hoping to use this for a family function on May 5th. Your help would be greatly appreciated!

Thank you

  1. Support Staff 1 Posted by Jorge Oliva on 30 Apr, 2018 12:07 AM

    Jorge Oliva's Avatar

    You need to disable the laptop webcam so the Logitech can work

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac