OS does not support this version

Patricia Schultz's Avatar

Patricia Schultz

24 Sep, 2022 06:41 PM

I just tried to sign onto my Sparkbooth 4. My MacBook Pro says the developer needs to update the software. I believe I purchased the Premium License in 2013 and have only used it for personal use maybe 3 times for family and a friends wedding, never charging anything. Do I need to pay for another version of the software or can mine be upgraded. Thank you.

  1. Support Staff 1 Posted by John on 24 Sep, 2022 06:59 PM

    John's Avatar

    Newer MacOS versions no longer support 32 bit applications like Sparkbooth
    4. You can downgrade your OS to version 10.14 which will run Sparkbooth 4.
    Or you can upgrade to version 7 which will run on the newer MacOS. Version
    7 is a paid upgrade
    https://secure.sparkbooth.com/upgrade

  2. John closed this discussion on 23 Nov, 2022 03:13 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac